re = /^(\d{4}|\d{6})$/m
str = '50532
201
20.02
53d24
465a5
502356
503543546
1234
21321'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end