package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w]+([-_\s]{1}[a-z0-9]+)*$`)
var str = `_______`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}