package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\( (?: [^()]* | (?-1) )* \))|(\[ (?: [^][]* | (?-1) )* \]))(*SKIP)(*F)|\h*,\h*`)
var str = `Wheat Flour [Wheat Flour, Wheat Gluten, Calcium Carbonate, Iron, Niacin (B3), Thiamin (B1), Ascorbic Acid], Water, Yeast, Salt, Vegetable Oils (Palm, Rapeseed, oils (sunflower, rapeseed)), Soya Flour`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}