$re = '/(?:(\( (?: [^()]* | (?-1) )* \))|(\[ (?: [^][]* | (?-1) )* \]))(*SKIP)(*F)|\h*,\h*/mx';
$str = 'Wheat Flour [Wheat Flour, Wheat Gluten, Calcium Carbonate, Iron, Niacin (B3), Thiamin (B1), Ascorbic Acid], Water, Yeast, Salt, Vegetable Oils (Palm, Rapeseed, oils (sunflower, rapeseed)), Soya Flour';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;