package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`alt=\"([^\"]*)\"`)
var str = `<img alt="t1" src=t1.jpg">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}