$re = '/alt=\"([^\"]*)\"/';
$str = '<img alt="t1" src=t1.jpg">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);