import re
regex = re.compile(r"\b([^0]....)\b", flags=re.MULTILINE)
test_str = ("21678 - 00000|00000|21678|64826\n"
"64826 - 00000|00000|21678|64826\n"
"45245 - 45106|45245|00000|00000\n"
"45106 - 45106|45245|00000|00000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")