re = /\b([^0]....)\b/m
str = '21678 - 00000|00000|21678|64826
64826 - 00000|00000|21678|64826
45245 - 45106|45245|00000|00000
45106 - 45106|45245|00000|00000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end