const regex = /(?=[A-Z]\s*\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[A-Z]\\s*\\.)', 'gm')
const str = `A. lorem ipsum dolor sit B . 41dipiscing elit sedC. lorem ipsum dolor sit amet D. 35 Consectetur adipiscing E .Sed do eiusmod tempor`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);