re = /(?=[A-Z]\s*\.)/m
str = 'A. lorem ipsum dolor sit B . 41dipiscing elit sedC. lorem ipsum dolor sit amet D. 35 Consectetur adipiscing E .Sed do eiusmod tempor'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result