$re = '/---: ([0-9SW]+)\n(([A-Z0-9 ]{3,3}): ([0-9SW]+ )?([0-9\.SW]{3,})\n){9}---/ms';
$str = '---: 150602000006S
TS : 150602000006S
EC1: 02429.523
EC2: 05604.110
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0002.41
PP : 0000.00
GC : 150602000000S 04695.446
---
---: 150602010006S
TS : 150602010006S
EC1: 02429.523
EC2: 05606.848
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0004.52
PP : 0000.00
GC : 150602010000S 04695.446
---
---: 150602020007S
TS : 150602020007S
EC1: 02429.523
EC2: 05609.839
EP1: ---: 150602020007S
TS : 150602020007S
EC1: 02429.523
EC2: 05609.839
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0002.32
PP : 0000.00
GC : 150602020000S 04695.446
---';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);