import Foundation
let pattern = #"---: ([0-9SW]+)\n(([A-Z0-9 ]{3,3}): ([0-9SW]+ )?([0-9\.SW]{3,})\n){9}---"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
---: 150602000006S
TS : 150602000006S
EC1: 02429.523
EC2: 05604.110
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0002.41
PP : 0000.00
GC : 150602000000S 04695.446
---
---: 150602010006S
TS : 150602010006S
EC1: 02429.523
EC2: 05606.848
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0004.52
PP : 0000.00
GC : 150602010000S 04695.446
---
---: 150602020007S
TS : 150602020007S
EC1: 02429.523
EC2: 05609.839
EP1: ---: 150602020007S
TS : 150602020007S
EC1: 02429.523
EC2: 05609.839
EP1: 05220.031
EP2: 02058.743
TI : 0001
PC : 0002.32
PP : 0000.00
GC : 150602020000S 04695.446
---
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)