use strict;
my $str = '97ksjfsldkjf
3dfkjdf*
9dkfj
4u39$@!
3u3423d9$@!
349348#$##
u23923829$
';
my $regex = qr/^(?=.*\d)(?=.*[!@#$&*])[A-Za-z\d!@#$&*]{8,32}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}