$re = '/^(?=.*\d)(?=.*[!@#$&*])[A-Za-z\d!@#$&*]{8,32}$/m';
$str = '97ksjfsldkjf
3dfkjdf*
9dkfj
4u39$@!
3u3423d9$@!
349348#$##
u23923829$
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);