#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b([A-Z]+[a-z]*)(kowie)([a-z]*)"
Local $sString = "asikowiecz" & @CRLF & _
"asikowie" & @CRLF & _
"Asikowierzyn" & @CRLF & _
"askowie" & @CRLF & _
"Askowierzyn" & @CRLF & _
"sikowie" & @CRLF & _
"Sikowierzyn" & @CRLF & _
"skowie" & @CRLF & _
"Skowierzyn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")