$re = '/\b([A-Z]+[a-z]*)(kowie)([a-z]*)/';
$str = 'asikowiecz
asikowie
Asikowierzyn
askowie
Askowierzyn
sikowie
Sikowierzyn
skowie
Skowierzyn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);