// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?\((.*)\).*$").unwrap();
let string = " claudiu.cismaru (Claudiu Cismaru) SPEAKER
radu.mihailas (Radu Mihăilă) SPEAKER
alex_macau (Alex Macau) SPEAKER
angela.milas (Angela Palcu) SPEAKER
andrada.rupacici (Andrada Rupacici) SPEAKER
gary_star (Gabi Gidei) SPEAKER
mihai.moje (Mihai Moje) ADMIN
paul.ciocmareanu (Paul Adrian Ciocmareanu) SPEAKER
ionut.marghidanu (Ionut Marghidanu) SPEAKER
eduard.hirsch (Eduard Hirsch) SPEAKER
simonabelintan (Simona Bitu) SPEAKER
ade.scutca (Adela Scutca) SPEAKER
roibu-florin (Florin Roibu) SPEAKER
live:oanamariavlad (Oana Poenar (Vlad)) SPEAKER
live:andrei.trancota (Andrei Trancota) SPEAKER
live:ozy24us (Emanuel Craciun) SPEAKER
adrian.mosneagu23 (Adrian Mosneagu) SPEAKER
daniela.busu (Daniela Busu) SPEAKER
live:florin.turdasan (Florin Turdasan) SPEAKER
live:daniel.boita_1 (Daniel Boita) SPEAKER
denis.buliga (Denis Buliga) SPEAKER
live:jean.goujon_1 (Jean-Baptiste Goujon) SPEAKER
jurjandrei90 (Andrei Jurj) SPEAKER
i_pasca (Ioan Pasca) SPEAKER
claudiu0386 (Claudiu Mardarasevici) SPEAKER
didi.popoviciu (Didi Popoviciu) SPEAKER
anda.lele (Alexandra Lele) SPEAKER
lorand.varga (Lorand Varga) SPEAKER
live:412602f6b1e34602 (Mihaela Lemeni) SPEAKER
lvudesign (Liviu Iancu) SPEAKER
octavia_stancu (Ava Stancu) SPEAKER
live:422c271cb4bb230c (Beatrice Blidariu) SPEAKER
live:raresistoc1_1 (Rares Istoc) SPEAKER
live:octavia_octi30 (Octavia Bradea) SPEAKER
live:paula.dragoman (Paula Dragoman) SPEAKER
live:sanda.popoiu (Sanda Popoiu) ADMIN
live:aciu.alexandru (Alexandru Aciu) ADMIN
live:sirbu.sorin.cristian (Sorin Sirbu) SPEAKER
live:ana.tutuianu_1 (Ana Tutuianu) SPEAKER
narcis.oancea (narcis oancea) ADMIN
live:raresturc (Turc Rares) ADMIN
live:8922ae5e5ee0572e (Eduard Daniel Cocirla) SPEAKER
adelabalans (Adela Balan) ADMIN
tudor.vioreanu (Tudor Vioreanu) ADMIN
live:madalin.crestescu (Madalin Crestescu) SPEAKER
live:bokorb (Bokor Béla) SPEAKER
live:lavinia.a.stoia (Lavinia Stoia) ADMIN
timoce.ana (Ana Tutuianu) SPEAKER
live:ded6104985160d9b (Mircea Grigoras) SPEAKER
iancic.bogdan (Bogdan Iancic) SPEAKER";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}