#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?m)^[A-Z]+\r?\n\S+\s+(\d+)(?:\r?\n\S+\s+\1)+$"
Local $sString = "ONE" & @CRLF & _
"1234234534564 123" & @CRLF & _
"34erewrwer323 123" & @CRLF & _
"123fsgrt43232 123" & @CRLF & _
"TWO" & @CRLF & _
"42433412133fr 234" & @CRLF & _
"fafafd3234132 342" & @CRLF & _
"THREE" & @CRLF & _
"sfafdfe345233 3234" & @CRLF & _
"FOUR" & @CRLF & _
"324ereffdf343 4323" & @CRLF & _
"fvdafasf34nhj 4323" & @CRLF & _
"fsfnhjdgh342g 4323"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")