import re
regex = re.compile(r"(?m)^[A-Z]+\r?\n\S+\s+(\d+)(?:\r?\n\S+\s+\1)+$", flags=re.MULTILINE)
test_str = ("ONE\n"
"1234234534564 123\n"
"34erewrwer323 123\n"
"123fsgrt43232 123\n"
"TWO\n"
"42433412133fr 234\n"
"fafafd3234132 342\n"
"THREE\n"
"sfafdfe345233 3234\n"
"FOUR\n"
"324ereffdf343 4323\n"
"fvdafasf34nhj 4323\n"
"fsfnhjdgh342g 4323")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")