// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).{0,10}005cc5.{0,10}").unwrap();
let string = "__comments-form,.author__avatar,.author__content,.author__urls-wrapper,.nav__list,.sidebar,.adsbygoogle{display:none !important;height:1px !important}}.highlight .cp{color:#d73a49}.highlight .n{color:#6f42c1}.highlight .nb{color:#005cc5}.highlightadfafljapfjpeiqeipqe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}