$re = '/<a.*\[monitory\].*href=["|\']([http:|https:]?[\/\/]?.*?)["|\']>/m';
$str = '<a [monitory] href="http://www.link1.com"><a [monitory] href="http://www.link2.com">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);