// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a.*\[monitory\].*href=["|']([http:|https:]?[\/\/]?.*?)["|']>"#).unwrap();
let string = "<a [monitory] href=\"http://www.link1.com\"><a [monitory] href=\"http://www.link2.com\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}