#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*(?:\r?\n(?!\r?\n).*)*?\bNew-York\b)(?=.*(?:\r?\n(?!\r?\n).*)*?\bBerlin\b).*(?:\r?\n(?!\r?\n).*)*"
Local $sString = "This is paragraph #1" & @CRLF & _
"New-York, London, Paris, Berlin" & @CRLF & _
"Some other text" & @CRLF & _
"End of paragraph" & @CRLF & _
"" & @CRLF & _
"This is paragraph #2" & @CRLF & _
"London, Paris" & @CRLF & _
"End of paragraph" & @CRLF & _
"" & @CRLF & _
"This is paragraph #3" & @CRLF & _
"New-York, Paris, Berlin" & @CRLF & _
"Some other text" & @CRLF & _
"End of paragraph" & @CRLF & _
"" & @CRLF & _
"This is paragraph #4" & @CRLF & _
"End of paragraph" & @CRLF & _
"" & @CRLF & _
"This is paragraph #5" & @CRLF & _
"Paris, Berlin" & @CRLF & _
"Some other text" & @CRLF & _
"End of paragraph"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")