import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^(?=.*(?:\\r?\\n(?!\\r?\\n).*)*?\\bNew-York\\b)(?=.*(?:\\r?\\n(?!\\r?\\n).*)*?\\bBerlin\\b).*(?:\\r?\\n(?!\\r?\\n).*)*";
final String string = "This is paragraph #1\n"
+ "New-York, London, Paris, Berlin\n"
+ "Some other text\n"
+ "End of paragraph\n\n"
+ "This is paragraph #2\n"
+ "London, Paris\n"
+ "End of paragraph\n\n"
+ "This is paragraph #3\n"
+ "New-York, Paris, Berlin\n"
+ "Some other text\n"
+ "End of paragraph\n\n"
+ "This is paragraph #4\n"
+ "End of paragraph\n\n"
+ "This is paragraph #5\n"
+ "Paris, Berlin\n"
+ "Some other text\n"
+ "End of paragraph";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}