const regex = /(\bChan\s[0-9]\b|\b,Chan\s[0-9]\b):\s|\s/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\bChan\\s[0-9]\\b|\\b,Chan\\s[0-9]\\b):\\s|\\s', 'g')
const str = `Chan 0: 2.50 0.12 13.92 83.46,Chan 1: 2.58 85.92 2.47 9.03,Chan 2: 5.00 85.0 33.33 6.64,Chan 3: 0.00 0.00 14.41 85.59`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}