re = /(\bChan\s[0-9]\b|\b,Chan\s[0-9]\b):\s|\s/
str = 'Chan 0: 2.50 0.12 13.92 83.46,Chan 1: 2.58 85.92 2.47 9.03,Chan 2: 5.00 85.0 33.33 6.64,Chan 3: 0.00 0.00 14.41 85.59'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end