use strict;
my $str = ' 1 UA 990J 28OCT SFOCDG 340P 1015A 29OCT fewfrgrgr grgrwg
OPERATED BY AIR CANADA
2 AF1830J 31OCT CDGMXP 900A 1025A 31OCT
OPERATED BY AIR CANADA
YYZ CHECK-IN WITH AIR CANADA
3 LH 259J 03NOV T MXPFRA 740A 900A 03NOV
OPERATED BY LUFTHANSA
MAD CHECK-IN WITH LUFTHANSA
4 DL2252Z 01OCT T SATDTW*SS1 1246P 454P
5 DL 98Z 01OCT T DTWCDG*SS1 608P 805A 02OCT W /DCDL /E
6 DL8322Z 02OCT W CDGBOD*SS1 935A 1050A /DCDL /E
OPERATED BY AIR FRANCE
grggf rge
7 DL9365Z 09OCT W BODAMS*SS1 1150A 140P /DCDL /E
OPERATED BY KLM ROYAL DUTCH AIRLINES
8 DL8178Z 09OCT W AMSSLC*SS1 500P 655P /DCDL /E
OPERATED BY KLM ROYAL DUTCH AIRLINES
fre
f
10 LH 454J 03NOV FRASFO 1005A 205P 03NOV
11 LH 454J 03NOV SFOKIV 205P 235P 03NOV';
my $regex = qr/(\d+)\s+(\w{2})\s*(\w{2,5})\s+(\w{5})(?:\s+|\s+(.)\s+)(\w{3})(\w{3})(?:\s+|(?:\s|\*)(\w{3})\s+)(\w{4,5})\s+(\w{4,5})(?:\s+(\w{5}))?.*(?:\n|$)((?:.|\n)*?)(\n\s*\n)?(?=\d+\s+\w{2}\s*\w{2,5}\s+\w{5}(?:\s+|\s+.\s+)\w{3}\w{3}(?:\s+|(?:\s|\*)\w{3}\s+)\w{4,5}\s+\w{4,5}(?:\s+\w{5})?|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}