import re
regex = re.compile(r"(\d+)\s+(\w{2})\s*(\w{2,5})\s+(\w{5})(?:\s+|\s+(.)\s+)(\w{3})(\w{3})(?:\s+|(?:\s|\*)(\w{3})\s+)(\w{4,5})\s+(\w{4,5})(?:\s+(\w{5}))?.*(?:\n|$)((?:.|\n)*?)(\n\s*\n)?(?=\d+\s+\w{2}\s*\w{2,5}\s+\w{5}(?:\s+|\s+.\s+)\w{3}\w{3}(?:\s+|(?:\s|\*)\w{3}\s+)\w{4,5}\s+\w{4,5}(?:\s+\w{5})?|$)")
test_str = (" 1 UA 990J 28OCT SFOCDG 340P 1015A 29OCT fewfrgrgr grgrwg\n"
"OPERATED BY AIR CANADA\n"
"2 AF1830J 31OCT CDGMXP 900A 1025A 31OCT\n"
"OPERATED BY AIR CANADA\n"
"YYZ CHECK-IN WITH AIR CANADA\n"
"3 LH 259J 03NOV T MXPFRA 740A 900A 03NOV \n"
"OPERATED BY LUFTHANSA\n"
"MAD CHECK-IN WITH LUFTHANSA\n\n"
"4 DL2252Z 01OCT T SATDTW*SS1 1246P 454P\n"
"5 DL 98Z 01OCT T DTWCDG*SS1 608P 805A 02OCT W /DCDL /E\n"
"6 DL8322Z 02OCT W CDGBOD*SS1 935A 1050A /DCDL /E\n"
"OPERATED BY AIR FRANCE\n"
"grggf rge\n"
" \n"
"7 DL9365Z 09OCT W BODAMS*SS1 1150A 140P /DCDL /E\n\n"
"OPERATED BY KLM ROYAL DUTCH AIRLINES\n"
"8 DL8178Z 09OCT W AMSSLC*SS1 500P 655P /DCDL /E\n"
"OPERATED BY KLM ROYAL DUTCH AIRLINES\n\n\n"
"fre\n\n"
"f\n"
"10 LH 454J 03NOV FRASFO 1005A 205P 03NOV\n"
"11 LH 454J 03NOV SFOKIV 205P 235P 03NOV")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")