$re = '/(?m)^(?>(?>\d+([ \t]|$)(?=.*\n(\2?+\d+\1)))+\n(?=\2$))+.*/m';
$str = '0 4 8 4
9 6 5 7
9 5 5 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);