re = /(?m)^(?>(?>\d+([ \t]|$)(?=.*\n(\2?+\d+\1)))+\n(?=\2$))+.*/m
str = '0 4 8 4
9 6 5 7
9 5 5 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end