#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>10)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>3X)(?P<sep_2>/|=)(?P<surface_coating>J3|)(?P<seal_material>V|)(?P<control_volume_flow>XY|)(?P<type_of_limit_switch>QM|)(?P<monitored_limit_switch_position>A|B|AB|)(?P<power_supply_of_limit_switch>G24|)(?P<special_version>SO40|SO60|SO150|)(?P<additional_details>(.|[0-9])*)$"
Local $sString = "Z2S10B1-3X/SO40" & @CRLF & _
"Z2S10-1-3X/" & @CRLF & _
"Z2S10A1-3X/" & @CRLF & _
"Z2S10B1-3X/" & @CRLF & _
"Z2S10-1-3X/V" & @CRLF & _
"Z2S10A1-3X/V" & @CRLF & _
"Z2S10B1-3X/V" & @CRLF & _
"Z2S10-4-3X/" & @CRLF & _
"Z2S10-2-3X/" & @CRLF & _
"Z2S10B2-3X/V" & @CRLF & _
"Z2S10-1-3X/SO14" & @CRLF & _
"Z2S10-3-3X/" & @CRLF & _
"Z2S10A2-3X/" & @CRLF & _
"Z2S10A3-3X/SO40" & @CRLF & _
"Z2S10B3-3X/SO40" & @CRLF & _
"Z2S10-1-3X/VXY" & @CRLF & _
"Z2S10B2-3X/" & @CRLF & _
"Z2S10B3-3X/" & @CRLF & _
"Z2S10-2-3X/V" & @CRLF & _
"Z2S10A2-3X/V" & @CRLF & _
"Z2S10A3-3X/" & @CRLF & _
"Z2S10A2-3X/SO40" & @CRLF & _
"Z2S10A4-3X/SO40" & @CRLF & _
"Z2S10B3-3X/V" & @CRLF & _
"Z2S10A1-3X/SO60" & @CRLF & _
"Z2S10B4-3X/" & @CRLF & _
"Z2S10-3-3X/V" & @CRLF & _
"Z2S10A1-3X/SO40" & @CRLF & _
"Z2S10A3-3X/VSO40" & @CRLF & _
"Z2S10B2-3X/SO60" & @CRLF & _
"Z2S10B2-3X/SO40" & @CRLF & _
"Z2S10A3-3X/V" & @CRLF & _
"Z2S10B1-3X/SO60" & @CRLF & _
"Z2S10A2-3X/SO60" & @CRLF & _
"Z2S10-4-3X/V" & @CRLF & _
"Z2S10A1-3X/VSO40" & @CRLF & _
"Z2S10A4-3X/" & @CRLF & _
"Z2S10B4-3X/V" & @CRLF & _
"Z2S10A1-3X/SO64" & @CRLF & _
"Z2S10B1-3X/VSO40" & @CRLF & _
"Z2S10A4-3X/V" & @CRLF & _
"Z2S10-1-3X=" & @CRLF & _
"Z2S10B1-3X=" & @CRLF & _
"Z2S10-1-3X/SO73" & @CRLF & _
"Z2S10A1-3X/SO73" & @CRLF & _
"Z2S10A1-3X/VSO60" & @CRLF & _
"Z2S10A4-3X/SO60" & @CRLF & _
"Z2S10B1-3X/VSO64" & @CRLF & _
"Z2S10B1-3X/VSO60" & @CRLF & _
"Z2S10B1-3X/SO64" & @CRLF & _
"Z2S10A3-3X/SO60" & @CRLF & _
"Z2S10-1-3X/VSO150" & @CRLF & _
"Z2S10-3-3X/VSO150" & @CRLF & _
"Z2S10A2-3X/VSO40" & @CRLF & _
"Z2S10-4-3X/SO150" & @CRLF & _
"Z2S10B2-3X/VSO60" & @CRLF & _
"Z2S10A2-3X/VSO60" & @CRLF & _
"Z2S10-2-3X/VSO150" & @CRLF & _
"Z2S10A3-3X/QMAG24" & @CRLF & _
"Z2S10B3-3X/QMBG24" & @CRLF & _
"Z2S10B1-3X/V/XY" & @CRLF & _
"Z2S10A4-3X=J3" & @CRLF & _
"Z2S10-1-3X/J3" & @CRLF & _
"Z2S10A1-3X/J3" & @CRLF & _
"Z2S10-2-3X/VJ3" & @CRLF & _
"Z2S10-4-3X/VSO150" & @CRLF & _
"Z2S10-1-3X/XY" & @CRLF & _
"Z2S10-1-3X=V" & @CRLF & _
"Z2S10-2-3X/MT" & @CRLF & _
"Z2S10B3-3X/SO60" & @CRLF & _
"Z2S10-1-3X/SO150" & @CRLF & _
"Z2S10A1-3X/XYSO40" & @CRLF & _
"Z2S10B1-3X/VXYSO40" & @CRLF & _
"Z2S10-3-3X/QMABG24" & @CRLF & _
"Z2S10-1-3X/J3V" & @CRLF & _
"Z2S10-4-3X=J3" & @CRLF & _
"Z2S10B1-3X/SO73" & @CRLF & _
"Z2S10-2-3X/SO73" & @CRLF & _
"Z2S10-2-3X/SO150" & @CRLF & _
"Z2S10B2-3X/XY" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")