import Foundation
let pattern = #"^(?P<mounting_type>Z)(?P<number_of_function>2)(?P<unit_type>S)(?P<unit_size>10)(?P<function_in_port>A|B|-)(?P<cracking_pressure>1|2|3|4)(?P<sep_1>-)(?P<unit_series>3X)(?P<sep_2>/|=)(?P<surface_coating>J3|)(?P<seal_material>V|)(?P<control_volume_flow>XY|)(?P<type_of_limit_switch>QM|)(?P<monitored_limit_switch_position>A|B|AB|)(?P<power_supply_of_limit_switch>G24|)(?P<special_version>SO40|SO60|SO150|)(?P<additional_details>(.|[0-9])*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Z2S10B1-3X/SO40
Z2S10-1-3X/
Z2S10A1-3X/
Z2S10B1-3X/
Z2S10-1-3X/V
Z2S10A1-3X/V
Z2S10B1-3X/V
Z2S10-4-3X/
Z2S10-2-3X/
Z2S10B2-3X/V
Z2S10-1-3X/SO14
Z2S10-3-3X/
Z2S10A2-3X/
Z2S10A3-3X/SO40
Z2S10B3-3X/SO40
Z2S10-1-3X/VXY
Z2S10B2-3X/
Z2S10B3-3X/
Z2S10-2-3X/V
Z2S10A2-3X/V
Z2S10A3-3X/
Z2S10A2-3X/SO40
Z2S10A4-3X/SO40
Z2S10B3-3X/V
Z2S10A1-3X/SO60
Z2S10B4-3X/
Z2S10-3-3X/V
Z2S10A1-3X/SO40
Z2S10A3-3X/VSO40
Z2S10B2-3X/SO60
Z2S10B2-3X/SO40
Z2S10A3-3X/V
Z2S10B1-3X/SO60
Z2S10A2-3X/SO60
Z2S10-4-3X/V
Z2S10A1-3X/VSO40
Z2S10A4-3X/
Z2S10B4-3X/V
Z2S10A1-3X/SO64
Z2S10B1-3X/VSO40
Z2S10A4-3X/V
Z2S10-1-3X=
Z2S10B1-3X=
Z2S10-1-3X/SO73
Z2S10A1-3X/SO73
Z2S10A1-3X/VSO60
Z2S10A4-3X/SO60
Z2S10B1-3X/VSO64
Z2S10B1-3X/VSO60
Z2S10B1-3X/SO64
Z2S10A3-3X/SO60
Z2S10-1-3X/VSO150
Z2S10-3-3X/VSO150
Z2S10A2-3X/VSO40
Z2S10-4-3X/SO150
Z2S10B2-3X/VSO60
Z2S10A2-3X/VSO60
Z2S10-2-3X/VSO150
Z2S10A3-3X/QMAG24
Z2S10B3-3X/QMBG24
Z2S10B1-3X/V/XY
Z2S10A4-3X=J3
Z2S10-1-3X/J3
Z2S10A1-3X/J3
Z2S10-2-3X/VJ3
Z2S10-4-3X/VSO150
Z2S10-1-3X/XY
Z2S10-1-3X=V
Z2S10-2-3X/MT
Z2S10B3-3X/SO60
Z2S10-1-3X/SO150
Z2S10A1-3X/XYSO40
Z2S10B1-3X/VXYSO40
Z2S10-3-3X/QMABG24
Z2S10-1-3X/J3V
Z2S10-4-3X=J3
Z2S10B1-3X/SO73
Z2S10-2-3X/SO73
Z2S10-2-3X/SO150
Z2S10B2-3X/XY
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)