import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=Violating URL: ).*?(?=$)";
final String string = "Site Searched: SomeSite\n"
+ "Keywords: OurCompany, lineman\n"
+ "Found violations: 3\n"
+ "Infringement Letter: N:\\Curriculum\\Copyright\\Infringement\\Infringement Letters\\Infringement letters\\SomeSite\\Infringement Copyright Letter SomeSite_06_18_2019_mjf\n"
+ "Response Email located: \n"
+ "N:\\Curriculum\\Copyright\\Infringement\\Infringement Letters\\Infringement letters\\Reponses\\06_18_19_RE DMCA Notice of Copyright Infringement\n"
+ " \n"
+ "Item Code: T251LM.K1\n"
+ "Submitter: The Real J. Evans\n"
+ "Submitted Date: 8/2/17\n"
+ "URL Title: OurCompany Test 2\n"
+ "Installer/Tech Job Information, Level I – 2nd Ed., Lesson 1\n"
+ "Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827671 \n"
+ " \n"
+ "Item Code: J221LM.M1\n"
+ "Submitter: The Real J. Evans\n"
+ "Submitted Date: 8/2/17\n"
+ "URL Title: OurCompany Test 3\n"
+ "Job Information 1, Level I – 2017 Ed., Lesson 10\n"
+ "Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827673 \n"
+ " \n"
+ "Item Code: OA2-1LM\n"
+ "Submitter: The Real J. Evans\n"
+ "Submitted Date: 8/2/17\n"
+ "URL Title: OurCompany Test 2-1\n"
+ "Outside 2nd Year, Level 1, Lesson 2\n"
+ "Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827549 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}