$re = '/(?=Violating URL: ).*?(?=$)/m';
$str = 'Site Searched: SomeSite
Keywords: OurCompany, lineman
Found violations: 3
Infringement Letter: N:\\Curriculum\\Copyright\\Infringement\\Infringement Letters\\Infringement letters\\SomeSite\\Infringement Copyright Letter SomeSite_06_18_2019_mjf
Response Email located:
N:\\Curriculum\\Copyright\\Infringement\\Infringement Letters\\Infringement letters\\Reponses\\06_18_19_RE DMCA Notice of Copyright Infringement
Item Code: T251LM.K1
Submitter: The Real J. Evans
Submitted Date: 8/2/17
URL Title: OurCompany Test 2
Installer/Tech Job Information, Level I – 2nd Ed., Lesson 1
Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827671
Item Code: J221LM.M1
Submitter: The Real J. Evans
Submitted Date: 8/2/17
URL Title: OurCompany Test 3
Job Information 1, Level I – 2017 Ed., Lesson 10
Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827673
Item Code: OA2-1LM
Submitter: The Real J. Evans
Submitted Date: 8/2/17
URL Title: OurCompany Test 2-1
Outside 2nd Year, Level 1, Lesson 2
Violating URL: https://www.SomeSite.com/?src_url=https://www.SomeSite.com/#flashcard/view/19827549
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);