package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z&]*$`)
var str = `fsdgs&erewwet&erewtrewt&sw&rewr
dr&erewwettwwtwte&
fgerer
kjdsfkj1
jhdsjdf&1
kjdhkdhfsf-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}