re = /^[A-Za-z&]*$/m
str = 'fsdgs&erewwet&erewtrewt&sw&rewr
dr&erewwettwwtwte&
fgerer
kjdsfkj1
jhdsjdf&1
kjdhkdhfsf-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end