#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(a+)(.*)(\1)"
Local $sString = "a1234a5"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)