use strict;
my $str = 'a1234a5';
my $regex = qr/(a+)(.*)(\1)/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";