# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^discography\\/(?:(ep|singles)\\/?$|type(?:\\/(?:(?:[^\\/]*[.])?(\d+)\\/?|[^\\/]+\\/?)?)?$)/discography\/releases.php?type=$1$2/gm;t' <<< "discography/type
discography/type/
discography/type/4
discography/type/albums.4
discography/type/albums/
discography/type/4//
discography/type//
discography/type/singles.4//
discography/ep
discography/ep/
discography/singles
discography/singles/"