$re = '/^discography\/(?:(ep|singles)\/?$|type(?:\/(?:(?:[^\/]*[.])?(\d+)\/?|[^\/]+\/?)?)?$)/m';
$str = 'discography/type
discography/type/
discography/type/4
discography/type/albums.4
discography/type/albums/
discography/type/4//
discography/type//
discography/type/singles.4//
discography/ep
discography/ep/
discography/singles
discography/singles/';
$subst = "discography/releases.php?type=$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;