#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b@[-\w\d.]*.[^gov\t]+\b"
Local $sString = "Love, Kenneth kenneth@teamtreehouse.com (555) 555-5555 Teacher, Treehouse @kennethlove" & @CRLF & _
"McFarland, Dave dave@teamtreehouse.com (555) 555-5554 Teacher, Treehouse" & @CRLF & _
"Arthur, King king_arthur@camelot.co.uk King, Camelot" & @CRLF & _
"Österberg, Sven-Erik governor@norrbotten.co.se Governor, Norrbotten @sverik" & @CRLF & _
", Tim tim@killerrabbit.com Enchanter, Killer Rabbit Cave" & @CRLF & _
"Carson, Ryan ryan@teamtreehouse.com (555) 555-5543 CEO, Treehouse @ryancarson" & @CRLF & _
"Doctor, The doctor+companion@tardis.co.uk Time Lord, Gallifrey" & @CRLF & _
"Exampleson, Example me@example.com 555-555-5552 Example, Example Co. @example" & @CRLF & _
"Obama, Barack president.44@us.gov 555 555-5551 President, United States of America @potus44" & @CRLF & _
"Chalkley, Andrew andrew@teamtreehouse.com (555) 555-5553 Teacher, Treehouse @chalkers" & @CRLF & _
"Vader, Darth darth-vader@empire.gov (555) 555-4444 Sith Lord, Galactic Empire @darthvader" & @CRLF & _
"Fernández de la Vega Sanz, María Teresa mtfvs@spain.gov First Deputy Prime Minister, Spanish Govt." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")