import re
regex = re.compile(r"\b@[-\w\d.]*.[^gov\t]+\b")
test_str = ("Love, Kenneth kenneth@teamtreehouse.com (555) 555-5555 Teacher, Treehouse @kennethlove\n"
"McFarland, Dave dave@teamtreehouse.com (555) 555-5554 Teacher, Treehouse\n"
"Arthur, King king_arthur@camelot.co.uk King, Camelot\n"
"Österberg, Sven-Erik governor@norrbotten.co.se Governor, Norrbotten @sverik\n"
", Tim tim@killerrabbit.com Enchanter, Killer Rabbit Cave\n"
"Carson, Ryan ryan@teamtreehouse.com (555) 555-5543 CEO, Treehouse @ryancarson\n"
"Doctor, The doctor+companion@tardis.co.uk Time Lord, Gallifrey\n"
"Exampleson, Example me@example.com 555-555-5552 Example, Example Co. @example\n"
"Obama, Barack president.44@us.gov 555 555-5551 President, United States of America @potus44\n"
"Chalkley, Andrew andrew@teamtreehouse.com (555) 555-5553 Teacher, Treehouse @chalkers\n"
"Vader, Darth darth-vader@empire.gov (555) 555-4444 Sith Lord, Galactic Empire @darthvader\n"
"Fernández de la Vega Sanz, María Teresa mtfvs@spain.gov First Deputy Prime Minister, Spanish Govt.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")