using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<!--.*?-->|<style(?s:.*?)</style>|<script(?s:.*?)</script>|rgb\(\d+, \d+, \d+\))(*SKIP)(*F)|\(([^()]*)\)\s*again";
string substitution = @"$1 - again";
string input = @"<!-- (Male) -->
<p>(Malē) again</p>
<p style=""font-family: "verdana"; font-size: 18px; color: rgb(0, 0, 0);"">Malē again</p>
<style>
code {
font-family: "verdana";
font-size: 18px;
color: black;
font-weight: bold !important;
line-height: 1.6 !important;
}
@media (min-width: 1281px) {
code {
font: 24px ""verdana"" bold !important;
}
}
</style>
<script type=""text/javascript"">
function googleTranslateElementInit() {
new google.translate.TranslateElement({pageLanguage: 'en'}, 'google_translate_element');
}
</script>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}