$re = '~(?:<!--.*?-->|<style(?s:.*?)</style>|<script(?s:.*?)</script>|rgb\(\d+, \d+, \d+\))(*SKIP)(*F)|\(([^()]*)\)\s*again~m';
$str = '<!-- (Male) -->
<p>(Malē) again</p>
<p style="font-family: "verdana"; font-size: 18px; color: rgb(0, 0, 0);">Malē again</p>
<style>
code {
font-family: "verdana";
font-size: 18px;
color: black;
font-weight: bold !important;
line-height: 1.6 !important;
}
@media (min-width: 1281px) {
code {
font: 24px "verdana" bold !important;
}
}
</style>
<script type="text/javascript">
function googleTranslateElementInit() {
new google.translate.TranslateElement({pageLanguage: \'en\'}, \'google_translate_element\');
}
</script>';
$subst = "$1 - again";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;