const regex = /(?<=From:).*(?= )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=From:).*(?= )', 'gm')
const str = `Available From:31-JAN-22 05:12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}