$re = '/(?<=From:).*(?= )/m';
$str = 'Available From:31-JAN-22 05:12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);