using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p(?:[^>]*|\r\n|\n)>(?:.*|\r\n|\n)(<img(?:[^>]*|\r\n|\n)>)(?:.*|\r\n|\n)<\/p>";
string input = @"<p data-entity-type="" data-entity-uuid="" style=""text-align: center;""><span><img alt=""image.jpg"" data-entity-type="" data-entity-uuid="" height=""349"" src=""image.jpg"" width=""620"" /><span title=""Click and drag to resize"">•</span></span></p>
<p><img alt=""image.jpg"" data-entity-type="" data-entity-uuid="" height=""349"" src=""image.jpg"" width=""620"" /></p>
<html>
<head></head>
<body>
some text here...
<p><img alt=""image.jpg"" data-entity-type="" data-entity-uuid="" height=""349"" src=""image.jpg"" width=""620"" />
</p>
</body>
</html>'
// Wanted result : <html><head></head><body>some text here...<img alt=""julie-bishop.jpg"" data-entity-type="" data-entity-uuid="" height=""349"" src=""/sites/default/files/inline-images/julie-bishop.jpg"" width=""620"" /></body></html>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}