# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<p(?:[^>]*|\r\n|\n)>(?:.*|\r\n|\n)(<img(?:[^>]*|\r\n|\n)>)(?:.*|\r\n|\n)<\/p>"
test_str = ("<p data-entity-type=\"\" data-entity-uuid=\"\" style=\"text-align: center;\"><span><img alt=\"image.jpg\" data-entity-type=\"\" data-entity-uuid=\"\" height=\"349\" src=\"image.jpg\" width=\"620\" /><span title=\"Click and drag to resize\">•</span></span></p>\n\n"
"<p><img alt=\"image.jpg\" data-entity-type=\"\" data-entity-uuid=\"\" height=\"349\" src=\"image.jpg\" width=\"620\" /></p>\n\n"
"<html>\n"
"<head></head>\n"
"<body>\n"
"some text here...\n"
"<p><img alt=\"image.jpg\" data-entity-type=\"\" data-entity-uuid=\"\" height=\"349\" src=\"image.jpg\" width=\"620\" />\n"
"</p>\n"
"</body>\n"
"</html>'\n\n"
"// Wanted result : <html><head></head><body>some text here...<img alt=\"julie-bishop.jpg\" data-entity-type=\"\" data-entity-uuid=\"\" height=\"349\" src=\"/sites/default/files/inline-images/julie-bishop.jpg\" width=\"620\" /></body></html>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.