#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+?[\d]{1,3}([-]{0,2}|[\s]+)?)?\(?(\d{3})\)?([-]{0,2}|[\s])?(\d{3})([-]{0,2}|[\s])?(\d{4})(\s?(([E|e]xt[:|.|]?)|x|X)(\s?\d+))?"
Local $sString = "1645162589000" & @CRLF & _
"1-718-444-1122" & @CRLF & _
"718-444-1122" & @CRLF & _
"(718)-444-1122" & @CRLF & _
"17184441122" & @CRLF & _
"7184441122" & @CRLF & _
"718.444.1122" & @CRLF & _
"1718.444.1122" & @CRLF & _
"1-123-456-7890" & @CRLF & _
"1 123-456-7890" & @CRLF & _
"1 (123) 456-7890" & @CRLF & _
"1 123 456 7890" & @CRLF & _
"1.123.456.7890" & @CRLF & _
"+91 (123) 456-7890" & @CRLF & _
"18005551234" & @CRLF & _
"1 800 555 1234" & @CRLF & _
"+1 800 555-1234" & @CRLF & _
"+86 800 555 1234" & @CRLF & _
"1-800-555-1234" & @CRLF & _
"1 (800) 555-1234" & @CRLF & _
"(800)555-1234" & @CRLF & _
"(800) 555-1234" & @CRLF & _
"(800)5551234" & @CRLF & _
"800-555-1234" & @CRLF & _
"800.555.1234" & @CRLF & _
"18001234567" & @CRLF & _
"1 800 123 4567" & @CRLF & _
"1-800-123-4567" & @CRLF & _
"+18001234567" & @CRLF & _
"+1 800 123 4567" & @CRLF & _
"+1 (800) 123 4567" & @CRLF & _
"1(800)1234567" & @CRLF & _
"+1800 1234567" & @CRLF & _
"1.8001234567" & @CRLF & _
"1.800.123.4567" & @CRLF & _
"+1 (800) 123-4567" & @CRLF & _
"18001234567" & @CRLF & _
"1 800 123 4567" & @CRLF & _
"+1 800 123-4567" & @CRLF & _
"+86 800 123 4567" & @CRLF & _
"1-800-123-4567" & @CRLF & _
"1 (800) 123-4567" & @CRLF & _
"(800)123-4567" & @CRLF & _
"(800) 123-4567" & @CRLF & _
"(800)1234567" & @CRLF & _
"800-123-4567" & @CRLF & _
"800.123.4567" & @CRLF & _
"1231231231" & @CRLF & _
"123-1231231" & @CRLF & _
"123123-1231" & @CRLF & _
"123-123 1231" & @CRLF & _
"123 123-1231" & @CRLF & _
"123-123-1231" & @CRLF & _
"(123)123-1231" & @CRLF & _
"(123)123 1231" & @CRLF & _
"(123) 123-1231" & @CRLF & _
"(123) 123 1231" & @CRLF & _
"+99 1234567890" & @CRLF & _
"+991234567890" & @CRLF & _
"(555) 444-6789" & @CRLF & _
"555-444-6789" & @CRLF & _
"555.444.6789" & @CRLF & _
"555 444 6789" & @CRLF & _
"18005551234" & @CRLF & _
"1 800 555 1234" & @CRLF & _
"+1 800 555-1234" & @CRLF & _
"+86 800 555 1234" & @CRLF & _
"1-800-555-1234" & @CRLF & _
"1.800.555.1234" & @CRLF & _
"+1.800.555.1234" & @CRLF & _
"1 (800) 555-1234" & @CRLF & _
"(800)555-1234" & @CRLF & _
"(800) 555-1234" & @CRLF & _
"(800)5551234" & @CRLF & _
"800-555-1234" & @CRLF & _
"800.555.1234" & @CRLF & _
"(003) 555-1212" & @CRLF & _
"(103) 555-1212" & @CRLF & _
"(911) 555-1212" & @CRLF & _
"18005551234" & @CRLF & _
"1 800 555 1234" & @CRLF & _
"+86 800-555-1234" & @CRLF & _
"1 (800) 555-1234" & @CRLF & _
"1234567890 Ext: 1123123" & @CRLF & _
"1234567890Ext: 1123123" & @CRLF & _
"1234567890 Ext:1123123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")