$re = '/\w*(?<=[^\Wz])zz(?=[^\Wz])\w*/m';
$str = 'buzz foozzbar zzbar wazzu trizzzbar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);